PBXes » English » Miscellaneous » RE: Calling SIP URL
Print Page | Recommend to Friend | Add Thread to Favorites
Post New Thread Post Reply
Author
Post « Previous Thread | Next Thread »
gor


Registration Date: 01.01.1970
Posts:

Calling SIP URL Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

Just starting out with PBXes

After setting up my outgoing trunk (sipgate.co.uk) I can't call any sip numbers e.g. xxxxxx@eu.voxalot.com
I can call sipgate SIP numbers e.g. xxxxx@sipgate.co.uk
I assume this is because sipgate.co.uk does not allow me to call SIP URL's. I can call PSTN numbers through sipgate fine.

If I delete all outgoing routing however, I can call the above SIP URL without problem. Presumably PBXes makes the connection directly. How can I set this up and have sipgate as my default PSTN provider?

Thanks in advance.

EDIT
Just looked in the logs when calling 2xxxx9@eu.voxalot.com
When default route is sipgate.co.uk then it calls' sipgate/2xxxx9' and fails

When I have no outnound route it calls 2xxxx9@eu.voxalot.com and the call works

When default route is voipcheap.co.uk then it fails in a similar fashion to sipgate.

It seems that PBXes is altering the SIP URI when an outbound route is set?


Sep 17 22:28:13 VERBOSE[6584] logger.c: -- Called sipgate/2xxxx9

Sep 17 22:29:32 VERBOSE[8675] logger.c: -- Called 2xxxx9@eu.voxalot.com

Sep 18 01:01:11 VERBOSE[69920] logger.c: -- Called voipcheap.co.uk/2xxxx9

This post has been edited 1 time(s), it was last edited by gor on 18.09.2011 at 02:39.

17.09.2011 23:39 gorstj is offline Search for Posts by gorstj Add gorstj to your Buddy List
Dia
Premium Account


Registration Date: 03.03.2006
Posts: 1443

RE: Calling SIP URL Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

In the above call scenario, PBXes is not altering any SIP URI's. When there is no Outbound route configured, it uses the default ENUM trunk to complete OnNet calls, to destinations such as Voxalot.

In order to complete calls to both OnNet and OffNet destinations, create an ENUM trunk and place it first on the Outbound Route you have created for your SipGate trunk.

That will take care of the OnNet calls, and the SipGate trunk in the second place will take care of the OffNet (PSTN) calls.

19.09.2011 10:51 Diafora is offline Search for Posts by Diafora Add Diafora to your Buddy List
gor


Registration Date: 01.01.1970
Posts:

RE: Calling SIP URL Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

Thanks you your reply.

I get the same behaviour if I add a an ENUM trunk and make that into an outbound route (I have tried that as my first and last route and as the only route)

(n.b. I thought ENUM was for converting a PSTN number into a sip address to avoid call costs, and hence not relevant in this prolem?)

If I have one outbound route (to sipgate) but put 'numbers starting by 44' in 'set destination' options then calling 2xxxx9@eu.voxalot.com works

I assume when I set the outbound route to 'valid for all numbers' it assumes that I want to send SIP URL there as well (which obviously I don't). Is this the intended behaviour?

Thanks for any further help

20.09.2011 12:10 gorstj is offline Search for Posts by gorstj Add gorstj to your Buddy List
i-p
Super Moderator


Registration Date: 14.01.2006
Posts: 4518

RE: Calling SIP URL Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

Reason is you are calling SIP URLs consisting of digits before the @. That's why they get routed as phone numbers. Try calling alphanumeric addresses.

23.09.2011 10:28 i-p-tel is online Search for Posts by i-p-tel Add i-p-tel to your Buddy List
hal


Registration Date: 01.01.1970
Posts:

RE: Calling SIP URL Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

Is there a workaround to call a sip uri beginning with a number?

I have an analog pbx with a VOIP interface that has identities beginning only with numbers.

Maybe I can create an outbound route lo filter the identiy.

23.09.2011 18:07 halldis is offline Search for Posts by halldis Add halldis to your Buddy List
gor


Registration Date: 01.01.1970
Posts:

RE: Calling SIP URL Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

This certainly sounds like a bug?

28.09.2011 05:19 gorstj is offline Search for Posts by gorstj Add gorstj to your Buddy List
hal


Registration Date: 01.01.1970
Posts:

RE: Calling SIP URL Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

meanwhile I found a workaround.

Create a SIP extension.
point it to the SIP uri required.

Calls are directed to my extension. The pbx forward to my sip uri.

28.09.2011 21:24 halldis is offline Search for Posts by halldis Add halldis to your Buddy List
 
Post New Thread Post Reply
Go to:

Powered by Burning Board Lite 1.0.2 © 2001-2004 WoltLab GmbH
English Translation by Satelk