PBXes » English » Bugs » Webcall URL
Print Page | Recommend to Friend | Add Thread to Favorites
Post New Thread Post Reply
Author
Post « Previous Thread | Next Thread »
hir
Soho Account


Registration Date: 25.03.2014
Posts: 12

Webcall URL Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

Webcall URL stopped working about 2 weeks ago. I go to
https;//www1.pbxes.com/<acccountname>-<**********>
(as set in extension) in browser & the text that I set in the extension appears (proving that the URL set in the extension is recognised). I then enter a number & press call button it says "Dialling" but nothing happens. The extension is not called & nothing appears in System Log or Call Monitor.

Sipdroid Trigger Callback has also stopped working as it relies upon the Webcall URL above. I have the latest Sipdroid version (5.7 beta).

Sipdroid Trigger Callthru does not work. It ignores the Prefix & simply dials number entered using 'phone. I have included this info in case it helps with the above & realise that it might need a seperate thread.

03.06.2021 18:55 hiresonic is offline Search for Posts by hiresonic Add hiresonic to your Buddy List
i-p
Super Moderator


Registration Date: 14.01.2006
Posts: 4734

RE: Webcall URL Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

Webcall should be fixed now. We've made a testcall on your account.

Sipdroid callthru relies on features of the Android phone dialer which may have changed, and might not be possible with the present Android version on a specific phone. What you can do is try to find manually which special characters to enter into the dialer, to make the callthru happen. Then we can include them into the app.

03.06.2021 21:27 i-p-tel is offline Search for Posts by i-p-tel Add i-p-tel to your Buddy List
hir
Soho Account


Registration Date: 25.03.2014
Posts: 12

RE: Webcall URL Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

Thanks for fixing Webcall so quickly & info on Sipdroid Trigger Callthru. I will experiment with Sipdroid Callthru as you suggest & let you know of any success.

All now seems to be working including Sipdroid Trigger Callback & I will test fully & reply further if necessary.

To avoid confusion for anyone reading this I made an error in the 1st post - https; when I meant https:

03.06.2021 22:17 hiresonic is offline Search for Posts by hiresonic Add hiresonic to your Buddy List
jen
Soho Account


Registration Date: 18.08.2019
Posts: 12

RE: Webcall URL Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

Zitat:
Original von i-p
Sipdroid callthru relies on features of the Android phone dialer which may have changed, and might not be possible with the present Android version on a specific phone.

In my smartphone (Android 11, MIUI 12), "Trigger callthru" works with the following:

"Use WLAN", "Use 3G", "Use EDGE": all unticked

Anrufeinstellungen ("Call settings"?)
-> "Bevorzugte Anrufart" ("Prefered calling method"?):
Sipdroid

PBXes-Funktionen ("PBXes functions"?):
"Trigger calltru": ticked

Prefix for callthru:
0991234567,1234#

where (just schematically):

0991234567: Callthru access number, as specified in PBXes
1234: Callthru PIN, as specified in PBXes.

For calling, I have to click the button showing a "5" in a circle in Sipdroid.
The Android Phone app opens, and I enter the target phone number.
A PBXes voice asks me to enter the callthru PIN plus # but I simply wait. And then I will be connected to the target number.

EDIT: It might be also necessary to have set one of the browser apps as the standard browser app, as in the case of "Trigger callback".

This post has been edited 1 time(s), it was last edited by jen on 23.05.2022 at 10:22.

22.05.2022 13:34 jenmi7 is offline Search for Posts by jenmi7 Add jenmi7 to your Buddy List
hir
Soho Account


Registration Date: 25.03.2014
Posts: 12

RE: Webcall URL Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

Thanks.
I now have Sipdroid Callthru working.
Previously within Sipdroid I had 'Call Options'/'Preferred Call Type' set to 'Always ask' now with it set to 'Sipdroid only' as you suggest the calls progress as you describe - the only difference being that I am dialing from the Android dialer.

24.05.2022 23:15 hiresonic is offline Search for Posts by hiresonic Add hiresonic to your Buddy List
jen
Soho Account


Registration Date: 18.08.2019
Posts: 12

RE: Webcall URL Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

Zitat:
Original von hir
Thanks.
I now have Sipdroid Callthru working.
Previously within Sipdroid I had 'Call Options'/'Preferred Call Type' set to 'Always ask' now with it set to 'Sipdroid only' as you suggest the calls progress as you describe - the only difference being that I am dialing from the Android dialer.

Meanwhile also I dial from the Android dialer.
And in Sipdroid, I ticked "Trigger callthru" and "Use WLAN", and I unticked "Use 3G" and "Use EDGE".
Therefore:
When Sipdroid has connection to the internet via WLAN, callthru is not triggered.
When Sipdroid has no connection to the internet via WLAN, callthru is triggered.

26.05.2022 18:02 jenmi7 is offline Search for Posts by jenmi7 Add jenmi7 to your Buddy List
 
Post New Thread Post Reply
Go to:

Powered by Burning Board Lite 1.0.2 © 2001-2004 WoltLab GmbH
English Translation by Satelk